• Email not working

    From Trever@1:103/705 to All on Tue Jan 7 10:48:25 2020
    I had everything working correctly yesterday but today there seems to be an issue. According to the logs I am receiving email but when logged into the board it says I have no mail. Also when I connect with my email client it also
    says there are no new messages.

    Below are the log entrys that appeared in /var/log/messages related to the incoming email.

    Jan 7 10:32:41 sbbs synchronet: mail 0049 SMTP Connection accepted on port 25 from: 208.68.164.213 port 50422
    Jan 7 10:32:41 sbbs synchronet: mail 0049 SMTP Hostname: mars.getoutofhere.org
    [208.68.164.213]
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Receiving mail message from: <trever@tandj.org> to trever@sandboxbbs.com
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Content-Transfer-Encoding = 7bit
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP End of message (body: 2 lines, 8 bytes, header: 48 lines, 2945 bytes)
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Executing external mail processor: MailAuth
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Created message #3 from Trever Noggle [trever@tandj.org] to trever@sandboxbbs.com [#1]



    -Trever
    Sandbox BBS SSH bbs.sandboxbbs.com
    KB0YGA

    ---
    Synchronet Sandbox BBS
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Tue Jan 7 10:03:18 2020
    Re: Email not working
    By: Trever to All on Tue Jan 07 2020 10:48 am

    I had everything working correctly yesterday but today there seems to be an issue. According to the logs I am receiving email but when logged into the board it says I have no mail. Also when I connect with my email client it also says there are no new messages.

    Below are the log entrys that appeared in /var/log/messages related to the incoming email.

    Jan 7 10:32:41 sbbs synchronet: mail 0049 SMTP Connection accepted on port 25 from: 208.68.164.213 port 50422
    Jan 7 10:32:41 sbbs synchronet: mail 0049 SMTP Hostname: mars.getoutofhere.org [208.68.164.213]
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Receiving mail message from: <trever@tandj.org> to trever@sandboxbbs.com
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Content-Transfer-Encoding = 7bit
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP End of message (body: 2 lines, 8 bytes, header: 48 lines, 2945 bytes)
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Executing external mail processor: MailAuth
    Jan 7 10:32:42 sbbs synchronet: mail 0049 SMTP Created message #3 from Trever Noggle [trever@tandj.org] to trever@sandboxbbs.com [#1]

    Maybe try using the ;MAIL sysop command to see all the mail on the system. Perhaps you're not logging in as user #1?

    digital man

    Synchronet/BBS Terminology Definition #68:
    SSJS = Server-side JavaScript
    Norco, CA WX: 67.7F, 22.0% humidity, 1 mph W wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Tue Jan 7 11:15:09 2020
    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 10:03 am

    Your suggestion of using :MAIL worked. I was able to see the email there. I am logged in as user1. (there are only 2 users for now) I am not able to see the email when I tell it to read email or when I pull it in from my mail client
    (thunderbird) Is is possible that some index somewhere got corrupted and if so
    is there a way to fix that. I had issues with a couple of DOVENET conferences the other day and I removed the files for them and that is now working again. I am just wondering if something else may have happened.
    -Trever
    Sandbox BBS SSH bbs.sandboxbbs.com
    KB0YGA

    ---
    Synchronet Sandbox BBS
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Tue Jan 7 11:17:18 2020
    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 11:15 am

    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 10:03 am

    Your suggestion of using :MAIL worked. I was able to see the email there.
    I am logged in as user1. (there are only 2 users for now) I am not able to see the email when I tell it to read email or when I pull it in from my mail client (thunderbird) Is is possible that some index somewhere got corrupted and if so is there a way to fix that. I had issues with a couple of DOVENET conferences the other day and I removed the files for them and that is now working again.
    I am just wondering if something else may have happened.

    Perhaps. You can run the "chksmb" utility on your data/mail base (e.g. "chksmb /sbbs/data/mail") and see if there are any reported problem.

    Who is the second user? Is it not possible that you're logging in as the second
    user?

    digital man

    Synchronet/BBS Terminology Definition #14:
    CR = Carriage Return (ASCII 13, Ctrl-M)
    Norco, CA WX: 71.6F, 19.0% humidity, 3 mph W wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Tue Jan 7 12:33:52 2020
    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 11:17 am

    Here are the results of the chksmb command. I also did a ;CHUSER to user 1 and
    still could not see my email

    bbs@sbbs:~$ /sbbs/exec/chksmb /sbbs/data/mail

    CHKSMB v2.30-Linux (rev 1.70) SMBLIB 2.61 - Check Synchronet Message Base

    Checking /sbbs/data/mail Headers

    100%

    Checking /sbbs/data/mail Data Blocks

    100%

    Checking /sbbs/data/mail Index

    100%

    Checking /sbbs/data/mail Hashes

    100%

    Status Total (=): 3
    Total Indexes (=): 3
    Active Indexes (=): 3
    Active Headers (=): 3
    Active Header Blocks ( ): 22 5,632 bytes used Active Data Blocks ( ): 7 1,792 bytes used Header Records ( ): 3
    Deleted Indexes ( ): 0
    Deleted Headers ( ): 0
    Deleted Header Blocks ( ): 0 0 bytes used Deleted Data Blocks ( ): 0 0 bytes used Oldest Message (import) ( ): 0 days (0 max)
    Largest Message (data) ( ): 1124 bytes (#2)

    /sbbs/data/mail Message Base is OK
    -Trever
    Sandbox BBS SSH bbs.sandboxbbs.com
    KB0YGA

    ---
    Synchronet Sandbox BBS
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Tue Jan 7 12:33:09 2020
    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:33 pm

    One other interesting thing is that when I connect with thunderbird to check email I do not see anything in /var/log/messages about that connection. But thunderbird reports there are no new messages.
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Tue Jan 7 12:53:14 2020
    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:33 pm

    And it does not appear to be sending email now either.

    Jan 7 13:51:38 sbbs synchronet: mail 0049 SMTP Connection accepted on port 587
    from: 66.119.60.66 port 1699
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Hostname: gatekeeper.ftnetworks.org [66.119.60.66]
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Trever authenticated using CRAM-MD5 authentication
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Trever relaying to external mail service: tandj.org
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Receiving mail message from: <trever@sandboxbbs.com> to trever@tandj.org
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Content-Transfer-Encoding = 7bit
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP End of message (body: 2 lines, 8 bytes, header: 12 lines, 470 bytes)
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Created message #4 from Trever Noggle #1 [trever@sandboxbbs.com] to trever@tandj.org [trever@tandj.org]
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Session thread terminated (2 threads remain, 12 clients served)
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Tue Jan 7 18:20:55 2020
    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:33 pm

    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 11:17 am

    Here are the results of the chksmb command. I also did a ;CHUSER to user 1 and still could not see my email

    bbs@sbbs:~$ /sbbs/exec/chksmb /sbbs/data/mail

    CHKSMB v2.30-Linux (rev 1.70) SMBLIB 2.61 - Check Synchronet Message Base

    Checking /sbbs/data/mail Headers

    100%

    Checking /sbbs/data/mail Data Blocks

    100%

    Checking /sbbs/data/mail Index

    100%

    Checking /sbbs/data/mail Hashes

    100%

    Status Total (=): 3
    Total Indexes (=): 3
    Active Indexes (=): 3
    Active Headers (=): 3
    Active Header Blocks ( ): 22 5,632 bytes used Active Data Blocks ( ): 7 1,792 bytes used Header Records ( ): 3
    Deleted Indexes ( ): 0
    Deleted Headers ( ): 0
    Deleted Header Blocks ( ): 0 0 bytes used Deleted Data Blocks ( ): 0 0 bytes used Oldest Message (import) ( ): 0 days (0 max)
    Largest Message (data) ( ): 1124 bytes (#2)

    /sbbs/data/mail Message Base is OK

    Strange. How exactly are you trying to read the email?

    Do the message headers look normal when viewed with the ;MAIL command?

    A ;CHUSER 1 shoul do nothing if you're already logged in as user #1.

    digital man

    This Is Spinal Tap quote #21:
    So when you're playing you feel like a preserved moose on stage?
    Norco, CA WX: 63.3F, 30.0% humidity, 5 mph E wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Tue Jan 7 18:22:57 2020
    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:33 pm

    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:33 pm

    One other interesting thing is that when I connect with thunderbird to check email I do not see anything in /var/log/messages about that connection. But thunderbird reports there are no new messages.

    That is normal.

    POP3 connections are logged only with a "DEBUG" level log message and only when
    the "DEBUG_POP3" option is set in the [Mail] section of you ctrl/sbbs.ini file.

    digital man

    Synchronet "Real Fact" #21:
    The first commericial sale of Synchronet was to Las Vegas Playground BBS (1992).
    Norco, CA WX: 63.3F, 30.0% humidity, 5 mph E wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Tue Jan 7 18:24:23 2020
    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:53 pm

    Re: Email not working
    By: Trever to Digital Man on Tue Jan 07 2020 12:33 pm

    And it does not appear to be sending email now either.

    Jan 7 13:51:38 sbbs synchronet: mail 0049 SMTP Connection accepted on port 587 from: 66.119.60.66 port 1699
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Hostname: gatekeeper.ftnetworks.org [66.119.60.66]
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Trever authenticated using CRAM-MD5 authentication
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Trever relaying to external mail service: tandj.org
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Receiving mail message from: <trever@sandboxbbs.com> to trever@tandj.org
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Content-Transfer-Encoding = 7bit
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP End of message (body: 2 lines, 8 bytes, header: 12 lines, 470 bytes)
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Created message #4 from Trever Noggle #1 [trever@sandboxbbs.com] to trever@tandj.org [trever@tandj.org]
    Jan 7 13:51:39 sbbs synchronet: mail 0049 SMTP Session thread terminated (2 threads remain, 12 clients served)

    That looks correct: your mail server received an email (via SMTP) for relay. At
    some point later, you would see the "SendMail thread" attempt to deliver the mail message, if the SendMail thread is enabled (which it is by default).

    digital man

    Synchronet/BBS Terminology Definition #16:
    DCD = Data Carrier Detect
    Norco, CA WX: 63.3F, 30.0% humidity, 5 mph E wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Wed Jan 8 04:18:47 2020
    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 06:20 pm

    It appears to be showing as I would expect. Here is the the output.
    Main 0:00:03 [3] DOVE-Net [17] Synchronet Sysops: ;MAIL

    Reading All E-mail (1 of 1): L

    Start with number [1]: 1

    From To A Subject
    1 Janis Kracht trever@sandboxbbs.com N Re: Zone 1 Node Number Application Form

    Reading All E-mail (1 of 1): 1


    Subj: Re: Zone 1 Node Number Application Form
    To : trever@sandboxbbs.com #1
    From: Janis Kracht (janis@filegate.net)
    Date: Tue Jan 07 2020 12:23 pm UTC-5:00 (17.9 hours ago)

    Hi Trever,

    Thank you for sending in an application to rejoin Fidonet - we're always
    glad to see our friends return. :)

    I'm going to contact the Regional Coordinator in your area, Terrence
    Barlow (Terry). He or one of his network coordinators will be in touch
    with you shortly.

    In the meantime, if you need any of the following files, you can pick
    them up here:

    The latest standard Fidonet nodelist:

    http://www.filegate.net/nodelist/NODELIST.Z03 (zip archive contains NODELIST.003)

    The latest list of Fidonet file archive tag names: http://www.filegate.net/info/filegate.zxx (ASCII text file)

    The latest list of Fidonet Echomail tag names: http://www.filegate.net/backbone/BACKBONE.NA (ASCII text file)

    The latest binkp compatible Fidonet nodelist (for argus and it's clones): http://www.filegate.net/ipfn/i-argus/i-argus.z03 (zip archive contains argus.txt)

    If you have any questions, just let me know :)

    Take care,
    Janis



    --

    http://www.filegate.net/ http://www.filegate.net:8090/bbbs janis@filegate.net
    For info about Fidonet, visit http://www.fidonet.ca/

    Reading All E-mail (1 of 1):



    -Trever
    Sandbox BBS SSH bbs.sandboxbbs.com
    KB0YGA

    ---
    Synchronet Sandbox BBS
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Wed Jan 8 04:20:30 2020
    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 06:24 pm

    Apparently that is not working either. This email never showed up in the mail list that I posted a minute ago.
    -Trever
    Sandbox BBS SSH bbs.sandboxbbs.com
    KB0YGA

    ---
    Synchronet Sandbox BBS
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Wed Jan 8 17:03:43 2020
    Re: Email not working
    By: Trever to Digital Man on Wed Jan 08 2020 04:18 am

    It appears to be showing as I would expect. Here is the the output.

    It definitely looks normal. And what happens when you hit 'R' from the mail menu, exactly (when logged in as user #1)?

    digital man

    Synchronet "Real Fact" #25:
    The Digital Dynamics company ceased day-to-day opperations in late 1995.
    Norco, CA WX: 55.3F, 75.0% humidity, 7 mph E wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Wed Jan 8 17:04:15 2020
    Re: Email not working
    By: Trever to Digital Man on Wed Jan 08 2020 04:20 am

    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 06:24 pm

    Apparently that is not working either. This email never showed up in the mail list that I posted a minute ago.

    I'm not clear what you're saying. Apparently *what* is not working either?

    digital man

    Synchronet/BBS Terminology Definition #28:
    FREQ = File Request
    Norco, CA WX: 55.3F, 75.0% humidity, 7 mph E wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Wed Jan 8 18:55:29 2020
    Re: Email not working
    By: Digital Man to Trever on Wed Jan 08 2020 05:04 pm

    Re: Email not working
    By: Trever to Digital Man on Wed Jan 08 2020 04:20 am

    Re: Email not working
    By: Digital Man to Trever on Tue Jan 07 2020 06:24 pm

    Apparently that is not working either. This email never showed up in the
    mail list that I posted a minute ago.

    I'm not clear what you're saying. Apparently *what* is not working either?

    digital man

    Synchronet/BBS Terminology Definition #28:
    FREQ = File Request
    Norco, CA WX: 55.3°F, 75.0% humidity, 7 mph E wind, 0.00 inches rain/24hrs
    I sent and email that the log shows if accepting the email. Yet it was never delievered to any mail box ;MAIL does not show it at all.
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Wed Jan 8 18:56:57 2020
    Re: Email not working
    By: Digital Man to Trever on Wed Jan 08 2020 05:03 pm

    hitting R from the main menu only shows me net DOVENET messages. No interenet email
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Nightfox@1:103/705 to Trever on Wed Jan 8 19:49:07 2020
    Re: Email not working
    By: Trever to Digital Man on Wed Jan 08 2020 06:56 pm

    hitting R from the main menu only shows me net DOVENET messages. No interenet email

    Personal email is a on a separate menu.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Wed Jan 8 20:38:15 2020
    Re: Email not working
    By: Trever to Digital Man on Wed Jan 08 2020 06:55 pm

    I sent and email that the log shows if accepting the email. Yet it was never delievered to any mail box ;MAIL does not show it at all.

    Can you copy and paste the relevant log entries?

    digital man

    Synchronet/BBS Terminology Definition #43:
    JS = JavaScript
    Norco, CA WX: 49.6F, 89.0% humidity, 0 mph SSW wind, 0.00 inches rain/24hrs --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Trever on Wed Jan 8 20:39:50 2020
    Re: Email not working
    By: Trever to Digital Man on Wed Jan 08 2020 06:56 pm

    Re: Email not working
    By: Digital Man to Trever on Wed Jan 08 2020 05:03 pm

    hitting R from the main menu only shows me net DOVENET messages. No interenet email

    To read email, a user must hit 'R' from the E-mail menu: http://synchro.net/docs/user.html#ElectronicMailFunctions

    Have you been using 'R' from the main menu (of the default/classic shell) this whole time?

    digital man

    Synchronet "Real Fact" #98:
    The Synchronet Wiki (wiki.synchro.net) went online in April of 2010.
    Norco, CA WX: 49.6F, 89.0% humidity, 0 mph SSW wind, 0.00 inches rain/24hrs --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Thu Jan 9 20:24:07 2020
    Re: Email not working
    By: Digital Man to Trever on Wed Jan 08 2020 08:38 pm

    Turns out that something flakey happened to the VM that I was running this in so I have deleted the VM and am starting over. I should have it back online tomorrow.
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Trever@1:103/705 to Digital Man on Thu Jan 9 20:25:17 2020
    Re: Email not working
    By: Digital Man to Trever on Wed Jan 08 2020 08:39 pm

    No. I was going to the other option to read email. And the email was never there when I connected via pop3 using thunderbird
    --- SBBSecho 3.10-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)